
BASICS OF MOTIONSTUDIO

User Interface 
MotionStudio combines draw, paint and animation in one easy

work easy. 

Main Window  
Main Window is the actual work area of a MotionStudio
change to another frame, the new frame will be shown in the window. The frame size is displayed in a 
shadowed rectangle. 
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BASICS OF MOTIONSTUDIO 
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To change the frame properties, Frame properties, such as the color, are changed through 
Property Sheet.  

To show Property Sheet if it's not visible,  

• Double-click a point where there is no underlying objects - Or -  

• Double-click a frame in the Frame List window - Or -  

• Choose Object Properties from the Object menu - Or -  

• Press Alt + Enter  

If Property Sheet is visible, single click the above will update the property sheet 

To change the background color,  

1. Click on the Standard toolbar, - Or – 
2. Choose Animation Properties from the Frame menu. 2. Click the General tab and select a 

background color and click OK.  

3. To change the Grid Settings,  
4. Choose Grid Settings from the View menu.  

Frame List - Selection & Deletion 

Frame List is a list of snapshots of all frames in the current MotionGIF file. It provides an easy way to 
manage frames.  

To show/hide Frame List,  

• Click the Frame List button on the Standard toolbar - Or -  

• Choose Frame List from the View menu - Or -  

• Press Shift + F1.  

 

You can scroll through the list and click on any frame to work on.  

To select a frame  

• Click the frame you need in the Frame List - Or -  

• Press Shift + Left/Right Arrow keys to navigate  

 

To select more than one frame To select non-sequential frames, hold down the Ctrl key and click 
a frame to add one by one. To select a series of frames, hold down the Shift key and click the start and 
end frame.  

To duplicate frames Press the Duplicate Frames button on the toolbar to duplicate selected frames.  

To delete selected frames Press the Delete Frames button on the toolbar to delete the selected 
frames.  



 

 
Background  
Background is a layer behind all frames. It works the same way as a frame does. That is, it can have all 
kind of objects too. One file has one common background which appears on all the frames. You can add 
commonly used images, shapes to the background. So, no need to add one-by-one on each frame.  

 

Note: Diagonal lines indicate the background editing mode. When editing the background layer, all frame 

individual frame objects will not be visible. To edit / toggle the background, Click on the Standard 

toolbar, - Or - Choose Background from the View menu. - Or - Press F4.  

 



 

Library  
A Library file is a file that contains pre-made objects that can be reused in any MotionStudio file and any 
frame just a matter of drag & drop. A library file is saved with the extension MGL (MotionStudio Library 
file).  

You can create your own library files, such as stamps, shapes, pointers, clipart, callouts, and arrows.  

To show/hide Libraries, Click the Library button on the Standard toolbar - Or - Choose Library from 
the View menu - Or - Press Shift + F3 

 

To add objects to a library, 

 1. Make sure the library to which you want to add is the current one by clicking on the library title.  

2. Select your objects (hold down the Ctrl key for multi-selection), or group them together so they are in 
one group.  

3. Hold down the Alt key and drag the selected objects onto the library window. Then drop the objects.  

4. A new object icon should be created in the library. You may change the name by clicking the name 
below the icon. You can then just drag the object from the library and add to any frame.  

To open an existing library file, 

 1. Right-click the library window, and choose Open Library.... - Or - Choose Open Library... from the 
Tools menu  

2. Find and click on an MGL file to open. 



 To create a library file, 

 1. Right-click on the library window, and choose New Library. - Or - Choose New Library from the Tools 
menu  

2. Add objects to the library, and assign the file name in the Save dialog.  

Property Sheet  
Property Sheet lists all the properties of the currently selected object or multiple objects. Object actions 
are assigned by clicking on Actions in the property sheet.  

To show/hide Property Sheet,  

• Click on the Standard toolbar - Or -  

• Choose Object Properties from the Object menu - Or -  

• Press Alt + Enter - Or -  

• Double-click the selected objects  

 

To change a property,  

Click the item you need to change and type or select a value.  

Toolbox  
Toolbox contains a series of icons, each representing a specific tool. The currently selected tool is 
displayed highlighted. The toolbox works in a 'pick-a-tool-and-draw-an-object' fashion. To draw a 
freehand brush line, for example, you can pick the brush tool, and draw a brush line.  

 

  



EXPERIMENT NO: 2 

MOTIONSTUDIO FILES AND FRAMES 

 

Creating a New MotionStudio File  
A MotionStudio file is a file with the extension .MSF (MotionStudio File).  

To create a new file,  

• Choose New File from the File menu, - Or -  

• Press Ctrl+N.  

 

When a new file is created, the first frame is automatically added to the file. The default frame property 
values will be used to create the frame. See Adding a New Frame for the details.  

Frame Navigation  
Frames can be navigated through menu, navigation buttons or Frame List.  

To go to a frame,  

• In the Frame List window, find the frame you want to go, click the frame. - Or -  

• From the Go menu, choose Next Frame/ Previous Frame/First Frame/Last Frame. - Or -  

• Press Shift + arrow keys - Or -  

• Click the navigation buttons on the toolbar  

 

Note: Menu and navigation buttons will be enabled only if there are frames to be navigated.  

Adding/Duplicating frames  
A MotionStudio file has many frames. Although you work on one frame at a time, all frames can be 

navigated. To add a new frame,  

• Click the Add New Frame button on the Standard toolbar  

- Or –  

Press Ctrl + Insert - Or -  

• Choose Add New Frame from the Frame menu  

The frame default values will be used to create a new frame. 

To duplicate multiple frames,  

1. Select the frames you want to duplicate in Frame List.  

• To select non-sequential frames, hold down the Ctrl key and click a frame to add one by one.  

• To select a series of frames, hold down the Shift key and click the start and end frame.  

 

2. Press the Duplicate frames button on the Standard toolbar, or from the Frame menu.  

Duplicated single frame will be added after the current frame, and multiple frames will be added after the 
last frame.  



To change default new frame values,  

1. Click the Options button on the Standard toolbar - Or - Choose Options from the Tools menu  

2. Click on the Default New Frame Values tab and assign the values and click OK. You can also 
assign the default frame actions by clicking the Default Frame Action button.  

 

Playing a File  
To play a MotionStudio file is to show the file in the full-screen presentation or in a window. All objects will 
take actions assigned in design mode.  

To play a file,  

• Press F5 - Or -  

• Click the Play button on the Standard toolbar - Or -  

• Choose Play from the Go menu  

 

To change play-time options,  
1. Click the file properties button on the Standard toolbar, Choose File Properties from the File 

menu. 
2. Click the Play-time Options tab and select the settings and click OK. 

 
Window Play in a resizable window - The file will be shown in a normal window. Play in a frame size 
window - The file will be shown in a non-resizable window with the frame size. Play in full screen - The 
file will be shown in full screen. Zoomed - The file will be zoomed to fit the size of the window, either in a 
window or full screen.  



Menu  
Show full menu when right-clicked - Check to show all menu items when right-clicked.  

Navigation  
Show navigation bar - Check to show the normal navigation bar at play-time. Not available for EXE. Use 
3D hot navigation bar - Check to show the 3D hot navigation bar at play-time. Click to go to the next 
frame if there's no object - If checked, when you click anywhere on the frame where there's no 
underlying objects, it will go to the next frame.  

Creating an EXE File 
After making your MotionStudio file, you can click to create a single EXE file to be distributed. There's no 
need for the other end to have the MotionStudio development system or any other file to view and play 
your exe.  

To Create an Executable File:  

1. Choose Create EXE... from the File menu,  

2. Click File Properties... to set/confirm play-time options for the executable file and assign your file 

information which will appear in Help/About of the EXE.  

3. Specify the EXE file name and location, and click Save to create the stand-alone executable.  

 

Note: If you have an external program assigned in Actions/Mouse Click/Run Program, you need to 
distribute the external program along with the EXE.  

Default Folders  
MotionStudio provides a default folder setup feature for quick file importing and locating. It greatly 

reduces the time to locate external files. To set default folders,  

1. Click the Options button on the Standard toolbar - Or - Choose Options from the Tools menu  



 

2. Click on the Default Folders tab and assign the values and click OK.  

 

Use the last picked folder - Use the last used folder as the default folder. Use the following folders - Set the 

default folders to be used for each action. 

  



EXPERIMENT NO: 3 

OBJECT BASICS 

Creating an Object  
A frame can contain many objects. All drawing objects are scaleable.  

To add an object,  

• Choose a tool from the toolbox.  

• Place the mouse in the main window and find a start point.  

• Press down the left mouse button and drag to the size of your choice and release.  

 

The new object default values will be used to create the new object.  

To change the new object default values,  

1. Click the Options button on the Standard toolbar - Or - Choose Options from the Tools menu  

2. Click on the New Object Template tab and assign the values and click OK. When creating an 

object, only items applicable to the object will be used as the default.  



 

To add objects from a library file,  

• Open a library file.  

• Drag an object from the library to the frame and drop at the point of your choice.  

• You may repeat the step 2, drag & drop as many as you like.  

 

Selecting Objects and Formatting  
To select one object, Using the selection tool - hand, single click an object to make the object 
selected. 

 

To select more than one object, Hold down the Ctrl key and click an object. 

 

To select more than one object in an area,  

1. Choose the selection tool (hand) from Toolbox.  

2. Position the pointer where you want the area to begin, press the left mouse button, and drag to the 

point where you want the area to end. You will see a square is drawn when you drag the mouse.  



3. Release the mouse button to end the area.  

 

To select all objects on a frame,  

• Press Ctrl + A - Or -  

• Choose Select All from the Edit menu  

 

To move objects,  

1. Select the objects  

2. Drag the selected objects to a new location. - Or - Hold down the Shift key, press the left and right 

arrow keys to move.  

 

Note: if the grid is shown, objects are moved according to the grid height and width.  

To format objects, Formatting objects includes alignment, spacing and centering. The first selected 
object handle color is blue, and the other following objects are green. Formatting is based on the first 
selected object.  

1. Select more than one object  

2. Choose a format action from the Object menu.  

 

Deleting Objects  
To delete objects,  

1. Select the objects you want to delete. See Select Objects on how to select.  

2. Press the Delete key - Or - Choose Delete from the Edit menu  

Undo and Redo  
MotionStudio provides a multi-level Undo/Redo feature to make the design more enjoyable.  

Undo - undoes any changes made to a frame. Redo - re-applies actions that have been undone.  

To undo an action,  

• Press Ctrl + Z - Or -  

• Choose Undo from the Edit menu  

 

To redo an previously undone action,  

• Press Ctrl + Y - Or -  

• Choose Redo from the Edit menu  

 

Note: Undo/Redo only applies to the current frame. The history will be cleared when going to another 
frame.  

Fill and Line Colors  
Fill Color - currently selected object's main color. Border/Line Color - currently selected object's 
border/line color. You can change the object properties in Property Sheet. 



 

You can select a color from the standard web color panel (6X6X6 Cube) by clicking the color you want. The screen 

tip number is formatted as # WebColor Red, Green, Blue ( 0 - 255) 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



EXPERIMENT NO: 4 

OBJECT AND IMAGE EDITING 

Changing Object Properties  
To change the properties of an object,  

1. Select the object.  

2. Double click the object - Or - Right-click and choose Object Properties from the menu - Or - 
Choose Object Properties from the Object menu  

3. Change the properties in Property Sheet.  

 

Selection Pointer (Hand)  
It is the on-screen indicator that moves when you move the mouse. It selects objects to make the objects 
"selected".  

Please see Selecting Objects for multiple selections. 

You can import and create new images by using the image tool, and you also can edit the image using 
the powerful Image Editor.  

To import an image, You can import an image file and insert it to anywhere of your choice. Image 

files supported are, 

Bitmap files  .BMP  

JPEG files  .JPG, .JPEG, .JPE  

PNG files  .PNG  

GIF files (including animated GIF) .GIF  

TIFF files  .TIF, .TIFF  

TARGA files  .TGA  

PCX files  .PCX  

Portable Greymap  .PGM  

DIB  .DIB  

RLE files  .RLE  

Metafile  .WMF  



Enhanced Metafile  .EMF  

Icons  .ICO  

Cursors  .CUR  

Animation Cursors  .ANI  

Drag & drop - you can drag an image file from your desktop, Explore or Web browser and drop it directly on the 

frame. The dropped image will appear on the top-left of the frame with the original image size. - Or - Use preview 

1. Select the Image tool from the Toolbox.  

2. Choose an image file to import. 

 

1. Double-click the image. (when the "Edit image when double-clicked" checkbox is checked in the 

Options/General). - Or - Select the image and show the property sheet. Click the Image field. 

 
Note: Opacity has a blending effects. Here is a comparison of Opacity 50 and 100. 
 



 
2. The image editor features a wealthy collection of tools for you to edit your image. 

 
3. Click OK in Image Editor to save the changes. 

 
 
 



Text Object  
 
To add a text object to a frame,  
1.  Select the Text tool from Toolbox. 2. Click and drag to specify where the text is to start and 

end, and then type your text. You can either enter text on-the-spot by pressing Enter or, in 
the Text field in Property Sheet. 

 
Tip: To enter a return in the text, hold down the Shift key and press Enter. Note: Only the text with a 

True-type font can be rotated. If a multi-line text object is rotated, only the first line is shown. 
 

Translucent Label  

By choosing "Translucent" Drawing Style, and a Fill Color on Property Sheet, object will have 
translucent effect. 



 

Rectangle Object  
To add a Rectangle object,  

1. Select the Rectangle tool from Toolbox.  

2. Position the mouse pointer where you want one corner of the rectangle, and drag to the opposite 

corner diagonally.  

3. Release the mouse  

 

A rectangle will be created with the default values set on the 'Default New Object Values' tab in the 
Options dialog box.  

Ellipse Object  
To add an Ellipse object,  

1. Select the Ellipse tool from Toolbox.  

2. Position the mouse pointer where you want one corner of the shape, and drag to the opposite 

corner diagonally.  

3. Release the mouse  

 

If you drag & drop the tool from the toolbox, an ellipse will be created with the default values set on the 
Default New Object Values tab in the Options dialog.  

Line/Arrow Object  
To add a Line object,  

1. Select the Line tool from Toolbox.  



2. Position the mouse pointer where the line starts, and drag to where the line ends.  

3. Release the mouse  

 

To add arrows to the line, select an Arrowhead with arrows in Property sheet.  

 

Polyline Object  
To draw a polyline,  

1. Select the Polyline tool from Toolbox.  

2. Position the pointer where you want the line to start, press the left mouse button, and drag to the 

spot where you want the line to go.  

3. One left mouse click makes a middle point. Press the right mouse button or, double click the left 

mouse button to terminate the line.  

 

To edit polyline points, You can add/move any editing point of a polyline. Please see Brush Object 

for the details. 



 

Brush Object 
The Brush tool is a freehand brush line tool which can be used to draw a line in any color and width (1- 
100 pixels).  

To draw a brush line,  

1. Select the Brush tool from Toolbox. 
2. Specify the starting point of the line. 
3. Press the left mouse button to start and drag to draw the line in any direction freely.  
4. After the line is drawn, all editing points are shown by default. (You can change this default in 

Options/General.) 

 

To edit a brush line,  

1. Select the brush line object. 
2. Press down on the Layout toolbar to show all editing points - Or - Right-click and toggle Edit 

Polyline Points in the menu  



3. To move an editing point: Place the mouse over the editing point until the move point cursor 
appears. To add a new point: Place the mouse over the point where you want the new point 
added until the cursor appears. To delete a point: Hold down the Shift key and place the mouse 
over the point until the cursor appears. 

4. Press the left button to move/add/delete the point.  

To change the default values for a new object,  

1. Click the options button on the Standard toolbar, - Or - Choose Options from the Tools menu.  
2. On the General tab, check/uncheck "Show editing points right after a polyline, brush or pen object 

is created". 

 
3. On the Default New Object Values tab, select the Border / Line color and width for new objects. Then, 

click OK 

 



Rotation  
Rotation features are supported for drawing objects, such as Text, Rectangle, Ellipse....  

To rotate an object,  

1. Select the object you want to rotate. 
2. Click on the Layout toolbar. The tracker handles will be changed to circles. - Or - Right-click and 

toggle Rotate/Free Rotate from the context menu. 

 
3. Drag any round handle to rotate freely to the angle you need. Then, release the mouse. 

 

Zooming  
MotionStudio provides free zoom from 10% to 1000%.  

To change the zoom ratio,  

Select the zoom ratio from the zoom combo box on the Layout toolbar. - Or - Type the ratio in the ratio 
combo box. - Or - Choose Zoom In/Out in the View menu  

To change the zoom ratio to 1:1, Click on the Layout toolbar. - Or - Type 100 in the ratio 
combo box. - Or - Choose Zoom to 1:1 in the View menu 

  



EXPERIMENT NO: 5 

INTERACTIVE ACTIONS & ANIMATION 

Interactive Actions  
Actions are assigned in design mode and will take effect at play-time. Actions include jumping to another 
frame, redirecting to a URL, running a program, playing sound and music, showing or hiding other objects 
...  

To assign an object's action, 1.Select the object. 2.Double-click the object. - Or - Click the 

Actions... item in the property sheet. 3. Assign actions in the Actions dialog boxes, Mouse Click 
Actions 

 

Highlight mouse click - You can assign the color to change when the mouse is clicked on the object.  

Sound - You can add a sound effect to the object when clicked. You can use built-in sound or import a 
sound file of your choice. 



Sound files supported by MotionStudio are, 

Wave files  .WAV  

MIDI files  .MID or .MIDI  

RMID files  .RMI  

MP3 files  .MP3  
 

Actions on other objects when (this object) is clicked - You can assign to show or hide any other 
object on the frame when this object is clicked.  

Hyperlink to - You can add a hyperlink to the object and then use it to go to a variety of locations — next 
frame, last frame, URL on the Internet, or to stop playing.  

Run Program - You can set to run an external program when the object is clicked. It doesn't have to be 
an exe, it can be a PDF, BAT, or Video file. 

Object Animation  
Frame-by-frame animation is labor intensive, and you have to add many frames to create an animation. 
Object animation is an effective way to create animation. Any object, a rectangle, an image, can be 
animated in the frame. That is, even if there is only one frame, you can create animation. There are 64 
built-in animation effects to choose from. There are two ways to assign animation, Freehand motion and 
built-in effects.  

To add a freehand motion path,  

1.Select the object. 

 2.Choose Add/Edit Object Animation from the Object menu. - Or - Click the Animation item in the 
property sheet. 

 3. Choose Use custom motion in the Object Animation dialog box 

 



4. Click the Set Motion Path button. The mouse cursor changes indicating that you can draw a motion path. 

 
5. After the freehand is drawn, a path will be attached to the object. The animation will be played at the 

same speed and location when you draw it. 
 

 
 

6. After the freehand is drawn, a path will be attached to the object. The animation will be played at the 

same speed and location when you draw it. 

To add a built-in animation effects, 1. and 2. Same as above. 3. Choose Use effects in the Object 

Animation dialog box. 

 

3. Choose the Effect type and Speed. Check AutoPreview to show the effect instantly.  

4. Choose timing on the Timing tab to fine tune the animation. 



 

Frame Actions  
Frame Actions refer to the visual effects, sound and animation of the frame. Each frame can have its own 
properties to take different actions at play-time.  

To change and assign the frame properties:  

• Click on the Standard toolbar - Or -  

• Choose Frame Actions… from the Frame menu  

 



Effect Effect – Assign an effect from the Effect list box. Speed – Assign how fast the frame effect 

will be. Sound Sound – Choose a sound from MotionStudio built-in sound list or import a 
sound/music file. Loop until effect ends – Check to keep playing the sound until the entire frame 
transition is complete. Don’t play now – Check to mute when changing. But the sound will be played 
at play-time.  

Redirection Delay - Delay time between after showing this frame and starting redirecting. Go to - 

Assign the actions from the list. Buttons Apply – Apply settings to the current frame only. Apply to 
All frames – Apply the settings to all the frames in the file. Cancel – Cancel any changes made in 
the dialog box. Help – Show the help file.  

Play-time Actions  
Play-time refers to the period the MotionStudio file is played. This is the time that all animation and 
interactive actions take place. For example, when an action is set to go to the next frame, when the object 
is clicked at play-time, the MotionStudio file will flip to the next frame. Depending on the frame actions, 
MotionStudio will show the next frame in different visual effects.  

To play a MotionStudio file, Click on the Standard toolbar - Or - Choose Play from the Go menu - 

Or - Press F5. 

  



EXPIREMENT - 6 

TWEENING 

Motion Tweens And Classic Tweens  
 

There are two different types of tweens for creating motion.  

Motion tweens, are powerful and simple to create. Motion tweens allow the greatest 

control over tweened animation.  

Classic tweens, are more complex to create. While motion tweens offer much more 

control of a tween, classic tweens provide certain specific capabilities that some users need. 

The differences between motion tweens and classic tweens include the following: 

• Classic tweens use keyframes. Keyframes are frames in which a new instance of an object 

appears. Motion tweens can only have one object instance associated with them and use 

property keyframes instead of keyframes.  

• A motion tween consists of one target object over the entire tween span. Classic tween allows 

tweening between two keyframes, containing instances of the same or different symbols. 

• Both motion tweens and classic tweens allow only specific types of objects to be tweened. 

When you apply a motion tween to non-allowed object types, Applying a classic tween converts 

them to graphic symbols. 

• Motion tweens consider text a tweenable type and do not convert text objects to movie clips. 

Classic tweens convert text objects to graphic symbols. 

• No frame scripts are allowed on a motion tween span. Classic tweens allow frame scripts.  

• Any object scripts on a tween target cannot change over the course of the motion tween span. 

• Motion tween spans can be stretched and resized in the Timeline and are treated as a single 

object. Classic tweens consist of groups of individually selectable frames in the Timeline. 

• To select individual frames in a motion tween span, Ctrl-click (Windows) or Command-click 

(Macintosh) the frames. 

• With classic tweens, eases can be applied to the groups of frames between the keyframes within 

the tween. With motion tweens, eases apply across the entire length of a motion tween span. 

Easing only specific frames of a motion tween requires the creation of a custom ease curve. 

• You can use classic tweens to animate between two different color effects, such as tint and 

alpha transparency. Motion tweens can apply one color effect per tween. 

• Only motion tweens can be used to animate 3D objects. You cannot animate a 3D object using a 

classic tween. 

• Only motion tweens can be saved as Motion Presets. 

• With motion tweens, you cannot swap symbols or set the frame number of a graphic symbol to 

display in a property keyframe. Animations that include these techniques require classic tweens. 

• There can be more than one classic or motion tween on the same layer, but there can't be both 

types of tween on the same layer. 

 


